Cloudflare backbone rerouting caused temporary network latency between non-US regions and US-East-1.
The rerouting resulted in increased response times and performance degradation for non-US customers routed through US-East-1.
US-East customers were not affected.
Issue resolved automatically once Cloudflare restored normal routing without manual intervention.
Impact
Non-US customers routed through US-East-1 experienced degraded performance.
API response times were elevated during the incident window.
Some requests experienced delays in loading.
No complete service downtime occurred.
No data loss was observed.
Resolution
Engineering team detected elevated latency through monitoring alerts.
Investigation confirmed issue was caused by Cloudflare backbone rerouting.
No infrastructure or application-level anomalies were identified.
Latency normalized automatically once Cloudflare restored normal routing.
Continued monitoring was performed after stabilization to ensure performance returned to baseline levels.
Remediation Items
Post-Incident Monitoring: Continue proactive monitoring across all regions to ensure sustained stability.
Posted May 22, 2026 - 11:06 UTC
Resolved
Resolved: We have continued monitoring the elevated latency issue affecting requests to the US-East region from other geographic regions for more than 15 minutes, and no further latency issues have been observed.
Services are operating normally across regions at this time. The incident has been resolved, and we will continue to monitor the environment to ensure ongoing stability.
Posted May 21, 2026 - 15:26 UTC
Monitoring
Monitoring: The elevated latency affecting requests to the US-East region from other geographic regions has now subsided, and services are operating normally.
Posted May 21, 2026 - 15:16 UTC
Update
Update: We are continuing to investigate the increased latency affecting requests to the US-East region from other geographic regions.
At this time, our investigation indicates that the issue is related to network latency impacting cross-region connectivity and is not caused by the Zuper application itself. Services and infrastructure within the US-East environment are operating normally.
We will continue to share updates as more information becomes available.
Posted May 21, 2026 - 14:54 UTC
Investigating
We are currently investigating an issue causing increased API latency for users accessing services hosted in the US-East region from other geographic regions.
Impact
Users outside the US-East region may experience:
Slower API response times Increased page load times Intermittent request delays